Browser Information

Minimum for Access Minimum for Support Your PC
Browser Any Internet Explorer 10+
Firefox 5+
Chrome 34+
Safari 8+
Not Supported
Cookies Yes Yes True
JavaScript Yes Yes False
Icon Legend
Your PC meets the minimum system requirements for support by IRMI.
Your PC does not meet the minimum requirements for support.
You may proceed, but IRMI does not support this PC configuration.
Your PC does not meet the minimum requirements to access IRMI Online.
You must update your PC configuration to proceed.
If you need assistance, please Contact Client Services

Optimize Your IRMI.com Experience

At IRMI our goal has always been to help you manage risk. With cyber risks increasing, we want to ensure that you and your company are well-protected. Keeping that goal in mind, we recommend that you use a safe, up-to-date web browser across your company.

The new IRMI.com does not support Internet Explorer Version 8 (IE8) or any previous versions. This decision was influenced by several factors:

  • We want to give you the optimal IRMI.com experience.
  • Microsoft no longer supports versions of Internet Explorer earlier than IE8.
  • Microsoft will end support of IE8 in January 2016. Review Microsoft FAQ here.
  • We want you and your company’s information kept safe.

The new IRMI.com homepage looks like this in current browsers:

IRMI Homepage

If your browser displays differently, you may consider updating your browser to a supported version.

IRMI suggests Google Chrome which is automatically updated and addresses security risks quickly. Download Google Chrome today!

Navigation

Social Media

User ID: Subscriber Status:Free